Cutting-edge Custom PC Builder
Cutting-edge Custom PC Builder
Search
Filters
Close
Wednesday, December 13, 2017 12:26:18 AM

Screen went blank all of a sudden

4 years ago
#88 Quote
I started my car yesterday and as soon as I touched the Car PC screen, it went blank and stayed blank. I changed the video inputs but could not see my backup camera or the video input indicator on the side. I started the car again after a couple of hours and the screen was working again.

Has anyone else experienced this issue?
2DIN Car PC V2 SE
Intel Core i5
4 GB RAM
64 GB Intel SSD
4 years ago
#89 Quote
E3io rep, could you comment on the blank screen issue that I observed.

Thanks!
2DIN Car PC V2 SE
Intel Core i5
4 GB RAM
64 GB Intel SSD
4 years ago
#92 Quote
Hi tariq_niazi,

We don't have reports of a similar problem, remember that this may be caused by the operating system, or something with video drivers like any desktop computer.

If you experience this issue again please report it immediately.
3 years ago
#128 Quote
I am experiencing the same problems.  I also get the blank screen, and no backup camera.  When I change the inputs, and cycle through and get back to VGA again, the screens shows up.  

Waiting a few hours before starting the car again will fix the problem sometimes.  I'm guessing the explanation for this is that the PC loses power completely after a few hours, and does a full shutdown.  The only solution I can think of is disabling hibernation so the PC does a full boot up(cold boot) every time.  If anyone else is experiencing this, please let us know if you find a solution.  Thanks.
top